*unofficial solution* Fixing permissions and ownership. This may take a while

When trying to install Waves Central im getting “Fixing permissions and ownership. This may take a while.”

I’m in OSX Monterey 12.3.1
MacBook Air M1

This is a normal function of Waves Central. Are you having an issue?

Yes it is indeed normal as incorrect permissions can cause plugins to not function as normal, or not function at all. This is just a precautionary measure to make sure everything runs as smoothly as possible for the user,

yeah, it doesn’t advance from there, I’ve been with that text for hours

yeah but I’m stuck in that text, I can’t install waves central. I already tried to reinstall the app but doesn’t work

Hi @esalazaranzures

Welcome to the Waves Community forum.

If you are experiencing permission issues, I suggest giving Central permissions by following these steps:

  1. Quit all apps.
  2. Launch your computer System Preferences .
  3. Go to Security and Privacy .
  4. Click on the Lock icon on the bottom left to make changes.
  5. Under Privacy on the left column, highlight Full Disk Access .
  6. Click on the + sign and add Waves Central.
  7. Reboot and launch Waves Central.

I hope this information will help.

Have a nice day :slight_smile:

1 Like

I have tried a few times but still not working

Hey !
I was having the exact same problem, then I remembered that I had deactivated this helper one day (I don’t remember why)


As soon as I reactivated it, everything went well again. Hope this will help !

1 Like

hey, how you have deactivated this? i am arunning the same problem andf cant overcome

Have you tried installing Central via an Admin account and running it up there first??

Where you have found this helper and how to deactivated this?

Hi @aleksanderpaul1999,

In case you still cannot log in to Waves Central, I strongly suggest contacting our Support team to save you the time and trouble of troubleshooting.

Have a good one.

I have connectietd to support but still nothing work for me

Hi @aleksanderpaul1999,

Checking our database I can see the issue was resolved and Central now runs perfectly on your end.

Enjoy your Waves plugins :metal:

same here, the fixing permissions is now running more than 12 hours. Can’t install anything on my new M1 studio computer. Tried it all, nothing works. Very baaaad!!!

I don’t have this issue, but I’m curious if this is only an M1 only issue. Maybe exclusively related to Native or Rosetta code base.

How’s everyone running it??

Hello, I can’t find this preferences on Windows 10, and I’m still having the issue. Is there any other way to fix it?

The following might work for this problem on macOS…

The problem seems to be that sometimes with OS updates the helper application (com.waves.central.InstHelper) in LaunchDaemon in Library gets deactivated.
Why that happens I don’t know but the following commands remove the helper application and reinstall/reactivate it.

I must issue a big warning here. It involves running ‘sudo’ (superuser) commands in the Terminal and as a superuser you can also delete essential parts of your system and make it kaput! So if you are not literate with the Terminal I would suggest call support. If you have an active Update plan (for even one plugin) they call in via Teamviewer Quicksupport and do their work on your computer.

Every line is a separate command and has to be entered and run individually in this order.

> launchctl print-disabled system
> cd "/Applications/Waves Central.app/Contents/Resources/res/external/data/"
> sudo ./uninstallHelperTool.sh
> sudo launchctl enable system/com.waves.central.InstlHelper

Hope this helps!

2 Likes

This worked for me. Many thanks. Luckily I am proficient in Terminal, so all went well. Is there anything out there as regards to software that could do this automatically I wonder.
cheers
Nyge

Not that I know of.
I guess this issue got introduced through heightened security on a system level in newer OSes. I had sort of the same problem with the Spitfire Audio install helper.