Waves Central. Fixing permission and ownership. This may take a while

When trying to install Waves Central im getting “Fixing permissions and ownership. This may take a while.” I’ve been waiting for a long time but nothing happens. The Security and Privacy and Full Disk Access do not help solve this problem. Reinstalling doesn’t help either.


MacBook Pro M1
Monterey 12.4

1 Like

Same here. Fixing forever and nothing happens!

1 Like

THE SAME HERE PLEASE HELP.strong text

1 Like

Hi, @J.Burger welcome to the Waves Forum. :slightly_smiling_face:

Please try and disconnect physically any USB device, eternal HD connected to the computer, and try relaunching Waves Central again.

If the issue persists [please contact our Support team directly (https://www.waves.com/contact-support :zap:) for a solution.

Hope you have a nice day.

All this won’t work. the problem is the installer helper, if I close it…it runs, but…no install…Come on waves, how can this be?

Not rocket sience, just fix a proper installer. Really pissed of I bought this software…after recommendations from a producer.

Screenshot 2022-09-25 at 14.47.29
totally sucks

guess you like 2,3 seconds Waves??

Just to mention, I just installed my Plugin Alliance setup from their installer within 30 seconds…

I want my money back!

I had this error pop up when reinstalling Waves after removing the MacOS Ventura beta. I went through the install process a couple times before I realized that all the plugins were actually there. So, when I got to the error I hit OK and went to settings and did a repair. This completed without issue and I haven’t had any problems.

Waves Central has been buggy for me after the last couple updates so hopefully they’ll get it sorted out. In the meantime, doing a repair install was a workaround that worked for me.

Hi, thanks for the reply… funny thing is that I am using Monterey, nothing else.
That installer helper is running now the whole day. Stopped it, tried again…same thing. When I close down the installer helper it suddenly moves, tries to install…but plops…and no install.
Really shitty software.

Hi, @orsonwelsh,

Since this issue can be caused due to various reasons I do suggest contacting Tech Support directly through the next link for a quick resolution.

Have a good one.