Waves Central OSX Big sur

Hello… need help…

Ive tried to purchase new plugin… cant open waves central. Searched the web and forum and no luck resolving an issue.
Central has encountered a system permission issue…

Ive granted all permissions… full disk permission as well…
Uninstalled…deleted all the left over folders… Cleaned my Mac… Reinstalled just freshly downloaded central and still the same…
Plugins i had do not work now…and cant buy the one i inteded…

MacbookPro 13 Big Sur 11.7

Hi @uratarevic,

Welcome to the Waves Forum.

Have you tried Contacting Technical Support ?

They will be able to tackle any Waves related Issue.

I did today. Solved!

Here is the solution should someone needs it:

Thanks for contacting Waves Tech Support.

To solve the issue, please follow the steps below:

  1. Go to the Applications folder.
  2. Right-click Waves Central and click Show Package Contents.
  3. Go to Resources > res > external > data
  4. Right-click [uninstallHelperTool.sh](http://. uninstallhelpertool.sh/) and click Open With > Terminal
  5. A browsing window will open, browse to Applications > Utilities, and double-click on Terminal.
  6. Note*: If Terminal is greyed out and can’t be clicked, please change the browsing settings to allow all applications.*
  7. Let the script run. Once it’s done, relaunch Waves Central.

If you are asked to grant permissions to Waves Central / InstlHelper Tools, please allow it and type in your computer’s user password.


Glad they were able to help. It’s a bit bizarre that it wouldn’t run in the first place. Probably something to do with the overzealous security systems that we are all facing today.

1 Like