WAVES.COM SPECIALS SUPPORT

Important Note about **macOS 10.15 Catalina**

Dear Waves users,

During October, Apple will release a new operating system, macOS 10.15 Catalina .
We are working closely with Apple to ensure that our software is compatible and that your Waves plugins and applications will work properly.
However, until we confirm full compatibility, we strongly recommend you remain on your current version of macOS.

In the meantime, please note:

  • Waves plugins v10 will open in macOS 10.15 Catalina but are not officially supported.
  • Waves’ eMotion LV1 mixer v10 will open in macOS 10.15 Catalina but is not officially supported.
  • Other Waves applications (MultiRack, StudioRack, SoundGrid Studio) are not supported and will not open in macOS 10.15 Catalina.
    We will update you very soon about macOS 10.15 Catalina compatibility developments.

Best regards,
The Waves Team

Hi there,

is there any progress with the macOS 10.15 Catalina?

When you say that plugins v10 and eMotion LV! mixer v10 are not officially supported, what do you mean with this?

Best regards
T.P.

Hi @theodoros.papadopoulos, Welcome to the forum!

We will change the notice here and on https://www.waves.com/support/tech-specs/system-requirements when we have updates.
We strongly recommend you remain on your current version of macOS.
At the moment, since we have not fully qualified OS Catalina all we can say is what is written above:

  • Waves plugins v10 will open in macOS 10.15 Catalina but are not officially supported.
  • Waves’ eMotion LV1 mixer v10 will open in macOS 10.15 Catalina but is not officially supported.
  • Other Waves applications (MultiRack, StudioRack, SoundGrid Studio) are not supported and will not open in macOS 10.15 Catalina.

“Not Supported” means that that it will open and work, but if issues arise we will not be able to troubleshoot or solve issues.

I can’t help but notice the absense of Tracks Live in this list.
Will Tracks Live be updated to support macOS 10.15 Catalina? We use it on a weekly basis.

Hi @ScottAudio12!

Tracks will also not be supported or open in osCatalina, as it is still a 32bit application.
Unfortunately I do not have an ETA for Tracks Live support on this OS.

I would really appreciate faster action on this. I don’t know why it’s taking so long, but everyone on Mac is having their whole computer held hostage to audio software companies dropping the ball on this release.

I can’t speak for other manufacturers, but we are working tirelessly on this update.
News will come soon.

Looking forward to having macOS 10.15 Catalina compatibility, whenever it comes. Thanks, guys. But what I am not looking forward to is having to bring up-to-date the Update Plan on my Diamond Bundle for $240 (!!!), in spite of the fact that I let it lapse because there were absolutely no compelling reasons to keep paying for it when I have been perfectly happy with what I have running so very well under macOS 10.14 Mojave, and the fact that the next update of ALL the plugins may be just to give us Catalina compatibility, something that I think should be made available to all Waves owners, regardless of Update Plan status. I think paying $240 to be able to run these plugins on the latest macOS is just not worth it. I may have to stick with Mojave.

Hi there,

So I would like to know what will happen to those who have spent £700+ on Waves DigiGrid hardware in regards to Catalina?

If this means SoundGrid is not coming to the platform, I am selling the hardware… as I think this is poor I am afraid. I went with the DigiGrid D because it is Ethernet and my whole studio is now networked together:

Vienna Ensemble Pro 7 + DigiGrid D (through a Netgear 108 8-port switch)

I also had plans to buy a SoundGrid Server at some point, since I close to Platinum in terms of plugins now…

Verry happy with this as an IT technician, but need to move to the likes of RME or others if SoundGrid is now off the table :frowning_face:

Hi @Shad0wLandsUK

We continue to develop the SoundGrid platform, and are working hard to enhance the future compatibility of Waves applications such as StudioRack and SoundGrid Studio. I do not yet have an ETA for an update for SoundGrid Studio which will work on Catalina - buy I assure you it will come, so I’d recommend keeping your D :slight_smile:

Hello Yishai :slightly_smiling_face:

Thanks for responding so soon

Now that is what I was waiting to hear!

Awesome news, I would not like to part with this anyway… very nice peice of kit

Thanks,

Good day

1 Like

I have just bought a new Macbook Pro 16 as my old Macbook has a hardware error. Now I realized that I cannot downgrade that machine to mojave…and soundgrid studio is not running on catalina. So my studio, which is completely running on the digigrid platform, is dead!

Do you have any advice what to do? Selling the new Macbook and buyung an old one is not really a option. (VMBox or anything else??)
How long will it take until catalina is supported? Is it a matter of days? or weeks? or months?

In October you wrote that the update is coming soon…2 Months is not really soon!

I am really happy with the system, but as I have to continue to work, I am forced to switch to another system, if you don´t solve this problem very soon!!!

Hi @huggi,

While I truly understand your situation and frustration, I do not have an ETA yet regarding the update, just that it is in the works as mentioned above.

One suggestion I can give to get you running in the meantime is to install a supported OS and SG Studio an external HD and boot from there. I know this is less than ideal - but it should work.

Best regards,
Yishai.

Hi Yishai,

thanks for your answer. Installing Mojave on a external HD doesn´t work, because it doesn´t have the drivers for the new Hardware…

But I have installed the LV1 Mixer and everything is working perfect with it!! Unfortunately I dont need all the features it has for live mixing, so spending 1200 bucks is a bit too much. Perhaps Waves could extend the trial period until the studio application ist released. Do you think this is possible?

Cheers,
Michael

Hi @huggi. Glad to hear this.
I cannot provide such an extension. Although I cannot guarantee or advise their answer, I suggest you contact our Sales department with this request.

How about the 9.92 versions, will they work in Catalina?

Hi @maarten,

No 9.92 will not work in Catalina.

V9 and V10 software versions were released long before Catalina was developed, so they are “not familiar” with this new OS.
We continue to develop only the latest version of Waves plugins - V11.
If you need plugins to work in OS Catalina, you will need to update the licenses to V11and install V11 software. You can find instructions here: https://www.waves.com/support/update-to-latest-version.

Thanks for the quick answer. If I upgrade to a bundle for a certain plugin (say I have the CLA-76 and I upgrade to CLA Classic Compressors) will I get the the latest version then for all the bundle, so including the plugin I already owned?

Copyright © 2019 Waves Audio Ltd. All rights reserved. Contact Us | Terms & Conditions | Privacy Policy