COSMOS does not show all samples

Hello!
First of all, I want to thank the developers for such a cool sample browser, COSMOS is wonderful!

My question is why, in the COSMOS view mode, it only shows me 3200 samples, even though I have 200000 samples that have already been scanned?

In Waveform and List view it shows 200000 samples, while in COSMOS mode it shows only 3200.
The COSMOS mode is exactly what I need, it’s an amazing way to pick up samples.

Does anyone have such a problem?

1 Like

I have the same problem.

After waiting a few hours for my main sample folder (~130 000 items, ~150 GB, ~250 subfolders) scan to finish no samples are added in the library and folder Info shows 0 samples.

After closing and re-opening program message pops up telling that library contents is changed (which is not true) and offers updating. Afer update still 0 samples.

I also tried remove/add folder and manually rescan multiple times. Does not help.

Note -
Another smaller sample folder (~40 000 items, ~60 GB) seems to be added correctly.

2 Likes

Same problem here. I first tried COSMOS with a library of 400,000 samples (Hey, after 20 years of this it grows!) but l can’t get it to work reliably with even 5% of that.

I get the same issue where reopening says something changed and it wants to start over from the very beginning. Ouch, I can’t even keep testing with that because it adds up to a lot of time lost cumulatively.

But the product is amazing and it will be perfect if they can get this resolved. I wish COSMOS had more feedback so we could understand why or where it’s failing. Maybe there’s a .log file or something?

Same problem here. I have a folder with samples from Roland Cloud. When I just wanted to add the top level folder it did not show me any samples. When I go some levels deeper in the directory and add it the samples suddenly show up.
However I added a folder with samples from a different company and they showed up when I added the top level folder.
The Roland samples have no issues whatsoever with any other software, be it the DAW or XO, etc.

I was confused by this too, but my understanding now is that the cosmos view is only showing One Shots not Loops, so this may be the case why the total is lower. You’ll notice the Loops icon in the menu is greyed out on Cosmos/star view.

It’s definitely not the point. I have much more one-shots than it is shown.

It’s also interesting that when I scanned the folder with all the samples again, it found another number of samples ⁓ 5000, which is also very small. If you delete a folder, and add it again, with a full scan, then it will find a different number of samples. But it always finds only a few thousand out of 200,000.

Just a thought…Are your missing samples .mp3 files? COSMOS does not yet support .mp3

Of course not. I have all samples in WAV and FLAC format, maybe some in MP3 as well.
Keeping samples in MP3 is definitely a bad idea… :smile:

I am having the same problem of COSMOS not finding samples. I have a very simple case of a folder that contains only 25 samples and COSMOS is not discovering any of them. All of the samples in this folder are WAV files. The filenames of the samples have the extension ‘.WAV’ in capital letters instead of ‘.wav’ in lower-case letters. If I copy some of these samples to a different folder and rename some of the files as *.wav as opposed to the original name of *.WAV and then have COSMOS scan this new folder it successfully finds the samples with the lower-case ‘wav’ extensions but not the ones with the original 'WAV" extension in capital letters.

This suggests that the problem is that COSMOS has a bug where it cannot “see” a WAV sample if the filename extension is in capital letters instead of lower-case letters. Very strange and should be easily fixable with a code change in COSMOS.

Waves team, please fix.

2 Likes

I am having issues too, every time it scans, I get a new number, usually the number is dropping, so it finds less samples every time. I have not acquired any new samples or changed my sample folder or hardware but every time I start the program it says it has to scan and then finds less.

Hi Guys,

Please note that in order for COSMOS to scan a sample, the following conditions must be met:

  1. The sample is in one of the supported formats: WAV, AIF, OGG, or FLAC (MP3 is not supported at this time)
  2. The sample has to be 60 seconds or less
  3. The sample’s sample rate has to be 44.1kHz-96kHz.

If some of your samples don’t meet these conditions, it could explain why you don’t see them listed in COSMOS.

I hope this information will assist.

Have a nice day :slight_smile:

Thanks for the answer. But no, that doesn’t explain why I don’t see them on the COSMOS list because those conditions are met.
:slightly_smiling_face:

In my case the samples that COSMOS is not “seeing” meet all three conditions listed above by ShayWaves. COSMOS can detect my samples as long as I change the filename extension from “.WAV” to lower-case “.wav”. My guess is that the code in COSMOS has a list of filename extensions that it will analyze, and if a filename extension is not in that list then COSMOS will not bother to analyze it. If true, then it simply seems (for my case) that the filename extension list algorithm needs to ignore the case of the letters in the extension and thus not be case-sensitive. Should be an easy fix in the underlying code in COSMOS.

Hi @Murrez

Did you scan the root directory of your samples or subfolders?
I suggest rescanning again by choosing the main folder without any subfolders.

If the issue persists, feel welcome to contact our Tech Support team.

Best regards,

I scan the root directory of course. There are a lot of subfolders, I did not think that this should be a problem. Scanning each folder individually - it will take a lot of time, there are a lot of folders and subfolders.

Hi,
so, if I understand correctly, the only way to avoid the “Changes were detected in your folders” message is to scan each and every single subfolder in my sample collection?

Just a remark to the scan-“issues”. I was wondering as well about the various numbers of samples - the frequently changes. However, a while back, while watching the re-scans (again and again), I realized that many samples attributed with new tags. So I’ve just been seeing it as the AI feature refining over and over again. While it can be a bit tiresomne at times, it is possible to stop it at most (except, sometimes the processes hang and a trip to task manager is needed).

Another note; about file-types: I’ve noted that NI’s formats is supported too. .nki for instance. Great!

My research shows that this is a problem with directory structure in combination with improper exception handling in Cosmos.

WavesPluginServer.exe which does actual scanning crashes on longer directory paths -
2022-04-10 16:07:23,933 ERROR [WinError 3] The system cannot find the path specified: ‘D:\Audio\Samples\Downloads\WA Production - Tech House Mega Pack 1\WAProd_Synthwave_Plane_Logic_v2\Synthwave Plane 100 BPM C#m\WAV MIDI Presets Logic Pro\Logic Pro Project\W. A. Production Future Synthwave Construction Kit_#3.logicx\Alternatives\000\Project File Backups’

List of files scanned so far does not get saved in SQLite database, so it seems that Cosmos is not finding any samples.

Check AppData\Local\Waves Audio\Logs\WavesPluginServer.log and delete /move deeply nested folders.

1 Like

If you’re having COSMOS issues, reinstall CR8 (or COSMOS). I was having issues where COSMOS wouldn’t rescan or scan new folders. Reinstalling CR8 through Wave Central fixed it for me.

When COSMOS plays up I’ve actually had some success deleting its folder from the User/Library/Application Support folder. For Windows you can probably find it in that %AppData% folder.

Just make sure to quote it first. You also may have to run up Activity Support or Task Manager and quite the WavesPluginServer process. Maybe.

Be warned though, if you do give this a go you will have to rescan your samples again. So it’s the kind of thing you try when nothing else seems to be working.