WAVES.COM SPECIALS SUPPORT

V13 plugins not working in Studio One Pro 5.4

Hi.
As mentioned in the other post on this topic the new Waves V13 plugins is not working in PreSonus Studio One Pro 5.4. The V13 plugins are not loading. I have tried absolutely everything Waves has suggested in order to fix it. It is still not working. Are you looking into this? I have a support case open for this. Super slow with no progress.

PreSonus support analyzed the logs and said that it was a Waves issue :wink:

Best regards,
Dag

You are talking about Windows 10? On Mac M1 Wave Plugs show up as normal in Studio One 5.4.

Hi. I have Windows 11.

Waves plugins are supposed to be compatible with Win 11 now. Although presently it just list Studio One 5.3 on their website so you shouldn’t be having any issues, in theory.

https://www.waves.com/support/tech-specs/supported-hosts

Do you just have V13 plugins on your system, or do you have a mix of versions??

Hi. I have a mix of 11, 12 and 13 versions.

same here after update to v13 i can use only v12 in studio one 5.4 pro win 11

Yeah there is a very good chance that Studio One and Windows will be alot more fussy in terms of Waves compatibility. To my knowledge only V13 has been tested for Win 11.

Dag, I got it to work by uninstalling the V12 versions and V13 versions, then reinstalling V13. Rescan plugins in Studio 5.4, Waves loaded again. Hope that works for you, I was having the same problem with V13 not loading.

1 Like

I’ve had issues mixing Waves versions in the past, but always got it sorted.

In this case I had problems with mixing v12 and v13 plugins on a Windows 10 machine. I removed some v12 plugins as per Waves instructions and installed some v13 versions. That broke some of my remaining v12 plugins. My fix was to install the v13 plugins first, test them (all OK) and then install the v12 plugins afterwards. I suspected some WaveShell issues; everything seems to be working for me now.

I had some v13 updates as part of my WUP and it seemed a shame not to be able to take advantage of the fixes in v13.

Hope this helps someone else. Let us know if it does.

Copyright © 2019 Waves Audio Ltd. All rights reserved. Contact Us | Terms & Conditions | Privacy Policy