[Solved] Waves Plug-ins don't load into StudioOne 5.5 (Windows 10)

I apologize if this is a duplicate. I have seen various threads, but none of them really match what I am seeing. I upgraded to the new Scheps plug-in today. It works fine in Cubase. When I try to add it to a channel in StudioOne 5.5:

  • All the Waves plug-ins appear in the list of available plug-ins as I am adding to the strip
  • If I select any of the Waves plug-ins from the list, nothing happens. In other threads, there was mention of an error message, but I get nothing at all.
  • Same thing if I drag the plug-in from the VST browser panel
  • No problem with any other 3rd party plug-ins, as far as I can tell.

It appears to me that all the Waves plug-ins are going into “Program Files (X86)”, indicating that the plug-ins are 32-bit programs. StudioOne documentation says it supports only 64-bit programs.

Am I screwed, or is there some easy solution to this?

It isn’t the end of the world. I don’t use StudioOne that much and don’t really use 3rd party plug-ins with StudioOne. But you would think these things would be compatible.

I resolved this by adding the folder to Studio One’s VST folders list.

StudioOne → Options → Locations → VST Plug-ins → C:\Program Files (x86)\Waves

But this is all wrong. There aren’t supposed to be any 64-bit programs in \Program Files (x86)

Why is Waves doing this? That’s not right.

Hi @ckparm,

Using Waves in StudioOne you should only be loading VST3.
The only path you should be directing Studio One is : C:\Program Files\Common Files\VST3, I suggest deleting the (x86) you added.

You can check the next article to try and solve the issue or you can Contact Technical Support to get their quick assistance.

The Waves VSTs aren’t in there. They are installed in the X86 folder. Why would Waves do that? That’s 100% wrong. You don’t install 64-bit code to the X86 folder. I didn’t override anything. This is how it defaulted.

Hi @ckparm,

Studio One will scan the Waveshells located in the VST3 folder mentioned in my previous reply to load the plugins. Part of the Waves Installation will indeed also install to the (x86) path.

If you require further assistance or information I suggest taking this with our support team they will gladly assist.

I am trying to explain that Waves doesn’t install the VSTs in C:\Program Files\Common Files\VST3. That was ALREADY in my scan folders for StudioOne. Nothing worked until I forced StudioOne to look at the (X86) path. Why is Waves putting 64-bit code in the (X86) folder?

If you do not have any Waveshell files located in the VST3 folder that means the installation was not complete or maybe those files were moved.

In any case, to properly troubleshoot the issue please Contact Technical Support.

Here’s what I have:

C:\Program Files\Common Files\VST3 has 5 Waveshell files, including 3 that have modified dates this week when I did my upgrades

C:\Program Files\VstPlugins has 5 Waveshell files, and all 5 were updated this week, even the ones I did not upgrade.

C:\Program Files (x86)\Waves has folders for Data, Plug-ins V13, Plug-ins V14, Waveshells V13 and Waveshells V14. There is a lot of stuff in sub-folders and most of it is dated this week. Some of it is obviously 64-bit, which is not supposed to be in the (X86) folder tree.

I’m not changing anything from this point. All of the Waves plugs worked with Cubase without any special action. None of the Waves plugs worked in StudioOne until I added C:\Program Files (x86)\Waves to S1s search list. After that, all the Waves plugs work in S1, so I’m leaving it alone.

I’m just noting this oddity here for others that have the same problem. IMHO, Waves should not be installing any 64-bit code in the (X86) folder.

Scanning the C:\Program Files (x86)\Waves path to load plugins is definitely not how it should be and might cause issues.

If you ever want everything set correctly as intended you can always reach support.

Waves installing in various locations as well as to C:\Program Files (x86) is not a problem and is done by default when you install using Waves Central.

Your Waves plugins only load as 64-bit.