WAVES.COM SPECIALS SUPPORT

SoundGrid Studio on Mac autostarting

Even though the “Launch Application On Startup” is clearly not checked, SoundGrid Studio consistently launches at login on all my Macs. Is there an easy way to prevent this?

image

Hi @ericbardes

Previous versions of SoundGrid studio had been assigned to the startup items list when installed,
as opposed to the new version, in which this option is set from within the application itself.

It might still be assigned there and affecting the new SoundGrid Studio.

You can try these steps to remove it from the list:

  1. Open System Preferences.
  2. Go to Users & Groups.
  3. Choose your nickname on the left.
  4. Choose Login items tab.
  5. Check SoundGrid Studio.
  6. Press the “–” sign below.
  7. You’re done.

SoundGrid Studio is not under System Preferences.

The V11 installer creates a file at

$HOME/Library/LaunchAgents/com.WavesAudio.SoundGridStudioSilent.plist

Because the installer runs as root, the file is owned by root and doesn’t revert it back to the installing user account. By using sudo and changing to my login user, I was able to edit the file by hand and change the following plist key from true to false.

<key>RunAtLoad</key>
<false/>

Hi @ericbardes,

Nice! I appreciate sharing the workaround you have found, however…

I must advise that this is not an official solution provided by Waves Support and I cannot guarantee it will work or not have any other affect on the software.
The setting Uri pointed to does work and there is no need for this workaround in general.

It is always best practice to contact Waves Tech support by phone or email with any issue where software doesn’t behave as it expected, like in this case. They can troubleshoot and offer official solutions.

Thank you

I’m having the same issue with Soundgrid Studio annoyingly starting automatically at startup. It’s not listed on the list referenced above and I’m not understanding Eric’s solution (above my paygrade). Please advise on an “official” fix for this.

Hi Yishai,

Actually, the official solution provided does not work. I noticed this happening after i mistakenly installed the v11 before going back to v9. The .plist file mod is currently the only solution that works for me. I am happy to provide the precise steps taken to get to this state if you desire.

Regards,
-Dana

I’m with Dana here.

Could Waves please offer a real solution? In the meantime I will be uninstalling an no longer using SGST.

-M-

So here’s a solution Yishal. Waves should immediately STOP doing Soundgrid Studio startup using non-GUI methods.

For anyone reading, simply erase the Soundgrid Studio plist from $HOME/Library/LaunchAgents since it’s only purpose is to startup (there’s no user or application specific preferences stored in this file.)

Also Vishal, either you don’t know much about the LaunchAgents folder / plists or you are FUDing the Waves users with this contact support line, Waves is stepping over the line by starting a GUI app with a LaunchAgent plist, this should be reserved only for essential services. There are mechanisms built into Macos to launch GUI apps at login and that’s what should be used.

It’s good enough for NI and TBH I was never asked by the software for consent to startup Soundgrid Studio.

It’s a waste of mine and everyone else’s time for this annoying failure in the software.

Escalate to development backlog.

Hi @jasonm23,

Thanks for the feedback and suggestions, this has been passed to our Dev team and will be considered.

Copyright © 2019 Waves Audio Ltd. All rights reserved. Contact Us | Terms & Conditions | Privacy Policy