WAVES.COM SPECIALS SUPPORT

SoundGrid Studio Crashes in Mac OS Catalina

SoundGrid Studio Crashes in Mac OS Catalina. I get the Message, " Soundgrid Studio 12.4.0 quit unexpectedly." I am on Mac Os Catalina 10.15.7. I am using a 12 core Mac Pro Mac 5.1 with an RX580 8 Gig video card and 48 Gigs of memory .Soundgrid Studio version says V12.0 in waves central , but in the problem report the Version says 12.4.0.
I installed SoundGrid studio and authorized it on my mac hd. Upon first try of trying to launch the app it failed. I tried the re-open option with the same result. I then un-installed the app via waves central and re-installed and authorized it again with the same result and failure message.
Is anyone having a similiar problem? Does anybody know how I can ge the app to properly launch?

I had the same exact thing happen to me. After about 2 weeks of this, i contacted support and the guy came to the conclusion that something was blocking the SoundGrid driver from starting and we couldn’t figure out what it was. So the solution was just to create a new profile, meaning a new user account, on the computer and load SoundGrid on that profile and it worked.
Hope this helps

Thanks for the info. I appreciate it. I tried this, but it didn’t work; however something odd happened.
I had a theory that maybe It was something within Catalina or one of its updates. I decided to try something that should technically not work, but that there was an off chance that it might with a stable release. Call it a hunch or gut feeling. I updated to Big Sur 11.2.3 (20D91). My Hunch paid off. Soundgrid Studio launched fine and setup fine. I used V12 plugins. The windows appeared fine. Not only did all of that work, but all of my previous work in getting MOTU Drivers, both Audio and Midi to work, worked as well. Including My Midi Timepiece AVs.

Copyright © 2019 Waves Audio Ltd. All rights reserved. Contact Us | Terms & Conditions | Privacy Policy