Opening/Auto-Updating Waves Center Corrupts Existing Live Sessions

The Version of Waves does not seem to matter, nor the version of Ableton Live as this is an ongoing issue I’ve had to deal with over the years many times and it has driven me away from ever relying on Waves in any serious music again.

Simply making the mistake of opening Waves Center, after much hard work mixing my songs; Once that forced auto-update runs (even if its only for WC itself), my current installed and working Waves plugins become “incompatible” with Live.
I’ve learned my lesson the hard way several times (…the definition of insanity) and have since switched many plugins over to Plugin Alliance to avoid the Waves nightmares. I only opened Waves Center this time, without thinking much to find a way to remove StudioRack (it causes problems for other apps in Win10 if they scan vst folders containing Waves causing the OS to confuse app icons). Since I opened WC, once again, any Ableton Live sessions I had/was still working on, can no longer use the previously working Waves plugins. (This happened in FL Studio as well when I used to use it)
I wish Waves would finally fix this. RVox is the last remain plugin I’m using, but here I am again due to not finding a replacement.
ScreenShot568

I like the Waves plugins a lot, but having to deal with so many of these issues has added up to so many days of wasted time troubleshooting and repeating the same down the road again and again.

Hi Shane,

Waves plugins should be loaded only as VST3 using the latest Ableton Live 11 (which was qualified and tested to work properly not VST2.

Even though other formats (VST2, AU) might load fine, they will eventually create various issues.

I suggest performing a hard rescan using these next steps, which should make all Waves VST3 plugins avilable, in case this was not solved I think it will be best to let our stellar tech team have a look and assist accordingly. :muscle:

Did Waves make the decision to break their VST2s?
The plugins I had loaded in the session worked fine a few weeks ago. Its like opening WC reminded them they’re not supposed to work, so they stopped. All other VST2 plugins work fine in Live, except for Waves apparently.

The more I think on it, I could’a swore I was already using VST3 for RVox at least since that was the only versions working. Its confusing how it works then doesn’t. Either way, all of them were working a few weeks back. Until Waves Central was opened. Waves have been very unreliable because of this.

Ive been working on a session for months (among others) that was nearly finished. It’s due in 5 days. So Waves suddenly becoming incompatible from opening Waves Central is a big setback and seems like a major issue worth addressing. It just becomes incompatible. Now the sessions need to be mixed again.

Welp, I finally got them working again.

…until the next time i accidentally open Waves Central.

Hi Shane,

Glad to see you managed to get the VSTs back, but as you said it’s a matter of time before issues will reappear as VST and Waves being used in Abelton is a no-go.

I suggest saving the presets of all those VST plugin components from Waves, and simply replacing them with the VST3 component of the plugin, next load your saved preset.

That way, you do not risk losing them as you experienced, additionally if anything happens using VST3 we can help and normally solve most Waves-related issues, which is not the case when using VST to load Waves in the latest Abelton Live.

Have a good one.