None of my plugins work any more

Hi all,

Not a very good story, I’m afraid. All my Waves plugins (26 of them) stopped working recently. Pulling up a plugin into WaveLab (specifically the Abbey Road Mastering, and a couple of other random ones for testing) gives me an error message. Pulling all of them up in Cubase does nothing.

I used to be very impressed by Waves tech support, but they have floundered with this one. None of their instructions have worked - so I’m essentially left with a pile of junk that I paid to get full licenses for. I suspect that I’m being coerced into buying the subscription plan, which is unethical at best.

I would hope that Waves, at the very least, would come out and tell me, hey, we’re not going to let you use them any more, so pay for them again or shut up. At least, then, we’ll know what their true intentions are.

I’m being forced to invest in new plugins now, and you’d best believe they’re not going to be Waves.

Thanks for listening to my rant. If anything changes, I’ll you know.


What Waves version? Mac or PC? and what OS version?

Was this all of a sudden or did you recently do an update?

What were their suggestions? Did you try repairing permissions or reinstalling?

Did you talk to someone from support or just following guides?

1 Like

Hi @Srinipad1,

Welcome to the Waves Forum.

Thank you for sharing your feedback. I see there is some progress in your support case and will make sure you’ll be contacted soon to solve all remaining technical issues.

I have multiple Waves plugins from V9 to V11.

Yes, this was all of a sudden. The plugins I frequently use (CLA Mixhub, SSL G channel, Abbey Road Mastering) all worked just fine a few weeks ago. I have not updated my hosts since then, although I did before that, with no problems.

I exchanged a bunch of emails with support, and they were the standard suggestions - repair, reinstall, reinstall V9 plugins with the offline installer. I did all of them multiple times. All the plugins show up in the Cubase and WaveLab plugin list. But when I try inserting any of those plugins I mentioned, WaveLab continues to give me an error message (I sent multiple screenshots to support), and Cubase does nothing.

I can only surmise that Waves wants me to either buy them again, or pony up for a subscription.


I don’t know if I’d call it progress - maybe progress towards closing the case, but certainly not towards solving my problem.

I did manage to reinstall, repair and reactivate them - multiple times now. And yet, I can’t use any of them, despite being able to use them just a few weeks ago. Nothing changed since then (updates etc, which were done but not since I was able to use them last).

I’m currently on hold with Waves for one last shot, since I was asked to call.

I’m afraid this is going to be the tried and true not-my-fault-check-with-Steinberg response, but we’ll see. If I can’t get these plugins to work, I’m going to uninstall all my Waves plugins and go with a more customer friendly vendor.

Latest update: I got detailed instructions on how to delete every Waves file from the computer from various places - there were about 14 different locations. I then uninstalled Waves Central, rebooted and reinstalled Waves Central, downloaded one V10 plugin, and tried to use it in Cubase insert - same thing. It does nothing. WaveLab gives me the same error message.

I’m giving up on Waves. I’d rather spend my money on a more ethical vendor.

I hope you guys all have better luck than myself.


Hi @Srinipad1,

Thanks for the update. We respect your opinion and are here to help in any way we can to make sure you can use your Waves plugins. As Tech Support mentioned during your correspondence, there are a few more things to verify if the steps you performed failed, as this might be a local issue on the computer/OS.

Usually if inserting a plugin and nothing happens, this is normally related to the Windows Redistributable files, that might be missing, corrupt, or even damaged.
Repairing those files, as the Tech representative suggested, should fix this issue.
Note that if the repair process was not performed properly, on all Redists files (from 2012 redists the modify>repaire option should be available) and the computer was not restarted once the repair was fully completed, the issue will persist.

Tech Support’s offer to fix the issue still stands and I am sure they will be able to get you U&R, but to do so, your cooperation will be required, you can contact them whenever it is convenient for you.

Let me put it to you this way. I have two hosts (Cubase and WaveLab) and plug-ins from about five vendors, including Waves. Every plug-in other than the Waves set works just fine, and the hosts work just fine. My computer works just fine. How could it possibly be a specifically local issue when everything else works fine?

I can go so far as to uninstall, reinstall, and repair Waves files. But I’m not going to monkey with the OS in a way that can impact the other apps - and not just music apps. The last time I searched for redistributables, all I found was Visual C++ files, which I presume are used in lots of places. What makes you think that repairing, or deleting, some of them is not going to mess up my computer? I can’t take that risk.

If your plugins have become that fragile, maybe you need to rewrite them. And, of course, give all registered users free updates. But we all know that ain’t happening.

Hi @Srinipad1,

Well If you did not follow the techie’s instructions and did not repair those Microsoft C++ files, it might explain why the issue persists.

Note that you do not have to take any risk and you can simply allow tech Support to do the job for you and guide you through the process over the phone, I can assure you they are highly trained in such types of troubleshooting.

Like I said if you wish to get this fixed Tech Support can help it is up to you.

And what if that isn’t the issue? We’ve already tried several approaches that we thought were the issue, which have turned out not to be. And, besides, how do you know I’m not taking a risk? If my computer begins to malfunction after fooling with the C++ files, what am I supposed to do? Reinstall Windows? Reinstall all my apps? And all because Waves can’t figure out a robust way to write their apps like every other vendor seems to do?

Lets consider a hypothetical, that I’m brand new to Waves, and that I’ve just bought all this stuff. Let’s also assume that my computer works fine so far - but Waves doesn’t. So now, we’re going to experiment with the guts of the OS just to force Waves to work? This is the situation I’m in right now. I have no Waves products on my computer. And yet, when I try to install one plugin to test it, it doesn’t work. And you’re telling me to muck with OS?


Here is what I consider to be the final update.

I received a survey from Waves, and in the interests of being fair, I contacted tech support again and said I’d give it one final shot. I went through repairing the distributable files, but was unable to repair two of them. Waves support said this is a Microsoft problem, so get those files fixed first. And, I was told, we just think that’s the problem, but we don’t know for sure.

So, after a long back and forth with Microsoft, I was told to reinstall Windows - and if you thought I was exaggerating in my last post, think again. That’s exactly what happened. Unfortunately, the in-place upgrade failed three times, and I was told to do a total reinstall that would wipe out everything, so better back up all your data and be prepared to reinstall all my apps. I said no, thank you.

Let this be a lesson to future Waves users. Something has changed in the recent past, and the products are simply not mission critical. They’re OK if you don’t care whether they work or not. If you’re a pro, beware - you will regret using these products on client projects, because you never know when they will stop working and the finger pointing will start.

Just for comparison, every other app works, even after the failed in-place upgrade. Music-wise, that includes Cubase, WaveLab, IK plugins, Brainworks plugins, Toontrack plugins - everything works, except Waves.

In all fairness, the tech support person was nice and helpful, but I can’t expect him to polish a turd, as some in the biz say.

I’m about to uninstall all my Waves products to streamline and protect my computer…and flush my Waves investment down the toilet.


Thank you for the update @Srinipad1

Damaged, broken Redist files (Windows OS-related files) indicate a damaged or broken Operating System.
The fact that those files could not be fixed, clearly states an issue with your Windows OS, which is also why Microsoft suggested a reinstall of Windows since some of the OS-related files are corrupt and could not be fixed as you stated.

Glad to hear all your other apps work, If you ever decide to reinstall Windows as Microsoft suggested to get the issue fixed, and are still in need of some help with your Waves plugins, Tech Support will be glad to help you out as long as your computer allows it.

Best of luck.

1 Like

Do you realize there was no issue until I tried to use Waves? Maybe I should get a new computer, just so I can use Waves?

It’s not you - it’s the rest of the world that’s messed up.