COSMOS won't work with external hard drives?

Running Mac OSX Monterey

Installed COSMOS and tried to add my sample folders (full of samples in the correct format). No files get added, even tho the folder is added to the list on the left of the screen. Really weird.

Note that my samples reside on an SSD connected via USB-C

Then I tried a small test folder of samples that resides on my computer’s hard drive (desktop). Opened COSMOS, tried to add folders and the samples appeared!

So, can only conclude that COSMOS doesnt work on attached drives. This is a major oversight IMHO - lots of people have their samples on a separate (large) drive

Anyone else noticed this or know when it will be fixed?


Such a poorly designed piece of software!

Cosmos does work on an external drive as that’s where my samples are and it’s fully functioning.

Perhaps, it might have something to do with the format of your drive??

If it’s any help, I have COSMOS working with an external APFS drive on Mac Catalina. It loaded and scanned about 500,000 samples. I do recall having to give it the correct security when prompted. Also I have fixed permissions issues with other Waves apps before via Waves Central, so I’m not sure if that aided it at all.

Hi @gypsymoth

Please note that in order for COSMOS to scan a sample, the following conditions must be met:

  1. The sample is in one of the supported formats: WAV, AIF, OGG, or FLAC (MP3 is not supported at this time)
  2. The sample has to be 60 seconds or less
  3. The sample’s sample rate has to be 44.1kHz-96kHz.

If some of your samples don’t meet these conditions, it could explain why you don’t see them listed in COSMOS.

If the issue persists, follow the steps below:

  1. Quit COSMOS (also from the upper system toolbar icon: MicrosoftTeams-image (5))
  2. Go to Applications > Utilities and launch Activity Monitor.
  3. Locate the process named WavesPluginServer and end it.
  4. In Finder, click on the Go menu, hold [Alt/Option] and click on Library .
  5. Go to Application Support > Waves Audio > Waves Plugin Server .
  6. Delete the file named cosmos.sqlite.
  7. Launch COSMOS and rescan your sample folders.
  • Please make sure to scan the root directory of your samples and not any of its subfolders.

I hope this info will assist, have a nice day. :slight_smile:

1 Like