Waves compatibility in macOS ventura

I can’t use waves in macOS ventura! when could we get an update?

They are working just fine here!

1 Like

Not working here. Mac sees my license dongle. Waves Central does not. No license, so no plugins.

1 Like

I’ve been seeing this issue around a bit, I believe its more to do with Ventura being fussy over the flash drive format.

Check this thread out…

1 Like

Im running High Sierra still and all of a sudden none of my waves plugins will work. I get the * rescan your licenses pop up. I’ve been trying to resolve and have tried install the legacy Wave Central driver 24.5.18 load everything off line as described and the reinstalling the latest Wave Central and installing the v10’s and still getting the error.
I’m on my 3rd day trying to get these Wave plugins to work. All my other plugins work flawlessly!
This should be a simply fix @#$%


No idea what I did really but they seem to be working again. I did uninstall and reinstall quite a few times and then all of a sudden they started working?


Well everything was working fine and now its back to the same error message again!
frustrated very frustrated


Its my internet security system creating the issue. So unless Waves changes to a iLok authorization or something similar then I guess I’m done with Waves. Oh well

I don’t think Waves will be going back to iLok, but there might be a way to possibly tell the Security app to ignore it, or recognise it as being a legit thing.

Follow up. Plugins work again once I turned on my wifi connection on my iMac. I guess my licenses are locked to my wifi connection but not to my Ethernet connection?
Issue appears to be resolved

1 Like

Hi @Nitocris,

Glad to read you managed to solve that.
If this ever happens again you can always check the next article to solve those types of issues.

Also worth mentioning is that Waves Central recognizes your computer according to your network adapter’s serial number (MAC Address).so when you changed to way you connect online Central shows your computer as a disconnected device in the Licenses section.

It may have to do with how you authorised them in the first place. Or if you are connected to ethernet via some kind of hub they sometimes have ways of messing up your MAC (Media Access Control) address which is what many licensing systems use to identify your computer.

Either way, if you want them to run via the ethernet you could try transferring the licenses back to the cloud using Central, disconnect your wifi and reconnect via ethernet, then reinstall the licenses. That should work… in theory.