Waves Central "Permissions Issue"

Bought some new waves plugins for the first time 2 days ago - installed Waves Central so that I could access my plugins and Waves Central will not open. It simply says that it has encountered a “permissions issue”.

Windows 10 is fully up to date. I tried numerous solutions, switching off all AV, opening as administrator etc. Going into UAC settings, switching off notifying me about allowing changes. Was contacted by Waves tech support and I tried all of their suggestions. Tried numerous ideas I found online, made sure internet proxy was disabled (it was)… Multiple uninstalls and reinstalls, cleared the cache… Still comes up with the same stupid message!

If I wanted to spend all this time ■■■■■■■ around with settings and screwing up my computer instead of making music I’d have just downloaded cracked software. At least that would have been free!

I’m yet to hear back from tech support but I’m not very hopeful of the outcome. Why can’t waves just provide an alternative means to download the software or fix this issue? It seems that so many people have had the same problem. I’ll just stick with other providers from now on and save all this headache. ■■■■!

There’s been a few that have encountered this issue and I think you were on the right track with some of the things you already tried, you just may not have hit the nail squarely on the head.

Support should be able to sort this out for you fairly simply… The operative word being “should”

Thanks Simon - thankfully I’ve been contacted by Waves and they’ve agreed to give me a refund. Definitely a preferable solution to me, rather than having to spend another of my evenings trying to figure out how to fix a problem that shouldn’t be occurring in the first place :smile:

1 Like