Waves Central can not run after install!


I bought a plugin but the client Waves Central seems terrible and I can not even get it to run properly. After installation I only get the error message below. I have turn off firewalls, turn off virus protection, made sure that I have full administrator access to my computer and made sure I have PLENTY of free space on my drive (300 GB should be enough?). Have anyone any idea on how to solve this?


Have you tried to restart windows?

I’ve had issues installing it in the past and all I had to do was restart windows.

Yes, I have restarted several times, still the same😔

I have never had issues installing in all the years I have been running Waves. I would reach out to support. They are very helpful.

I came across a couple of people earlier, one of them on ere. who stated similar behaviour. It seems it was due to Central auto updated and now it won’t run on their system. If this is the case here, I would think its a simple oversight on Waves’ behalf when they introduced the feature.

They wouldn’t gain anything from forcing Central updates on people if it no longer works. It jwill ust means Tech Support will be busy solving problems for users that could’ve easily been avoided.

It’s probably worth while raising the issue with Tech Support and make them aware of the situation, so they can maybe do an OS check before updating.


Thank you for your responses. I will contact tech support and see what they have to say. I hope that they won’t just send me the FAQ on what to try again, because i have already looked into that and nothing seems to help.

No other software seem to have a problem on my computer, so they should be able to just update their software. It seems absurd that i have to turn off every safety feature there is in Win 10 to get this to run when nothing else need that.

Ok, so there is not even a “send” button on the tech support page? I think i give up…

Re-loaded the page a couple of times and then i could apply my ticket. Weird!

1 Like

Damn, that sounds like a real problem. It might be due to a recent browser upgrade, but it did work.

You could always see if there is a relevant thread on here and try posting there, or creating your own. Hopefully the Waves guys lurking around here will actually see it and respond accordingly.

Hi @magnus.ardhammar,

I see one of our agents contacted you back a month ago, requesting further information and files in order to assist you with your Waves-related issues but got no reply back.

If you still experience any technical issues the best place to forward these is always @ Tech support

Have a great day ahead.

1 Like