Troubleshooting PC-to-PC connection

I have two PCs, and I want to use one as a VST instrument only box to route to my DAW.

I’ve done this before with great results, but I’ve been away from Soundgrid a while and now am not sure where I’ve goofed. I cannot get the main DAW instance of Soundgrid to see the VST instance.

DAW1: Win 11 Pro (main)
DAW2: Win 10 Pro (vst)
I/O: Digigrid D
Switch: Netgear GS108
Soundgrid Driver
Soundgrid Studio

-Each PC has a second network adapter exclusive to Soundgrid.
-Only IPv6 and Soundgrid enabled on those adapters… no other protocols (per Waves optimization guide)

In SG Studio:

DAW1 can see the I/O and itself.
DAW2 can see itself. I’ve also disconnected the I/O from the DAW1 inventory and DAW2 was able to see the I/O as well.

However, SoundGrid Studio running on DAW1 cannot see DAW2, so I can’t patch it in.

I’ve reinstalled drivers on DAW2.

Not sure what to look at next, as I’m not sure what SG Studio looks for when polling for other devices on the network.

Thanks for any suggestions. Happy to provide more details.

Well… solved… but I’m not sure how.

In the DAW2 Soundgrid app, just to see if I can make it available to add in DAW1, I set the local device to Shared.

Now DAW1 Soundgrid could see it as available to add!

Cool, but I don’t want DAW2 to be a shared device.

After adding DAW2 on DAW1 Soundgrid, I figured I needed to make DAW2 respect DAW1 as the controlling host, so I selected the Manage Device option under the DAW2 entry.

DAW2 then displayed a “SG Connect” icon with the label “SG Connect 1” (but still under the SG Driver column).


Wanting to try again, I removed the DAW2 (“SG Connect”) device, and… DAW2 then showed up as expected.


Well, it’s working. DAW1 is the host. DAW2 is patched in. I’m calling it a win.

But obviously, I’m not understanding how device discovery works between computers running Soundgrid. Happy to learn.


You only need one computer with Soundgrid Studio. Then just install the ASIO driver on the Daw2 machine. If they are on the same switch, you can see Daw2 as available on Daw1. Make sure you enable you NIC in soundgrid connect.


Thanks for the clarification! Makes perfect sense now.

1 Like

Hi @johnchop,

Even though it is always nice to find the solution on your own :muscle: don’t forget that Tech support is available almost at any time to provide assistance and setup information to save some time.