SSL EV2/WAVESHELL issue with FL studio

Hi all

I recently bought a few WAVES products for the first time with one of them being SSL EV2 channel strip however it doesn’t appear in ‘WAVESHELL’ when I open it up in FL studio. All the other products work despite all being installed exactly the same way in the exact same location. I’ve updated FL studio and reinstalled SSL EV2 but it still doesn’t appear. Are certain plugins meant to be installed or opened differently or should all plugins appear in WAVESHELL?

HI Davos, and welcome aboard.

The behavior where Waves plugins appear inside a Waveshell in FL usually signifies the wrong paths for Waves is scanned in FL.

Normally adding the following path: C/Program files/common files/VST3, does the trick , also make sure to remove any other path you added to FL for scanning Waves in cases others were added.

Check out this easy steps by step to perform a proper rescan in FL Studio.

1 Like

Hi thanks for your advice but I figured it out, when I installed the plugins I didn’t ask for the plugin manager in FL studio to rescan previously verified plugins and also to verify the new plugins. That seems to have fixed it :slight_smile:

1 Like