SOLVED: Waves plugins very slow to load

Posting this to several threads because lots of people seem to have different forms of this issue and I want to spread the word on what worked for me. Here’s my story…

I run Studio One 5.x with 100+ plugins on Windows 10. Mainly use Waves, SoundToys, Plugin Alliance, and Fab Filter EQ. Everything was working great and then one day it all stops. Loading projects that normally took seconds to load started taking 20+ minutes always getting stuck at loading the plugins. Each plugin took minutes. Waves plugins seemed to be the worst but Plugin Alliance was also slow.

I tried uninstalling and reinstalling all my plugins and the DAW and different versions of the DAW. I tried refreshing licenses, etc. nothing worked. After two days I’ve finally figured this out. Long story short is was my SD card reader! I had inserted an SD card (which I don’t use very often) and it was causing this issue:

google - “TechNet disk-id collisions with empty card-reader”

Simplified explanation: Waves and other plugin manufactures use your hardware configuration to build a unique key for your computer to keep track of the license. Every time you use the plugin they take a hardware inventory to makes sure the license is on the right computer. My guess is this SD card reader issue was causing that hardware inventory process to fail. This is not an issue with the DAW so this issue/solution is not unique to Studio One and should work on other DAWs.

Other symptoms of this issue were my computer was taking an extra long time to start/restart. Wave Central took a long time to start. Windows Explorer was very slow and my computer in general seemed to get stuck every once in a while. Also disk manager took forever to load getting stuck at “connecting to virtual disk service”.

Unplugging the SD card reader fixed everything. Projects load in seconds again. Computer boots fast again. Etc. Weird thing is I’ve had this SD carder for over a year and never had a problem. I guess this is the first time I’ve had an SD card sitting in the reader while using Studio One.

One clue was I had two phantom disk drives (and drive letters) that never disappeared even though no USB drives/sticks were connected. These were associated with two “Generic MassStorageClass USB Device” under “Disk drives” in Device Manager.

I should also note that if you are having the slow loading plugins issue, because of the hardware inventory process, it could be another piece of USB or other hardware and if it is not the SD reader you should systematically remove/add other hardware to see if that is the issue.

Hope this helps someone.



Hi Simon,

I observe exactly the same behaviour with the exception, that it doesn’t make a difference if the SD Card reader is connected or not. Reading your post I just tried it immediately.
I recently change from two 1TB drives to a single 4TB datadrive because I was getting short on space for my sample library. I replicated the same partition structure with the new drive but I guess I see the same hardware inventroy failure as you did. But I have no idea how to resolve it. :frowning:

But your post gives me hope there is a solution!

1 Like

I’ve over a hundred of plugins…all load flawlessly. This has been isolated to WAVES. See attached. On a lone MIDI track (no other tracks) 31 seconds to load Audio Track Mono and over 20 seconds to load HD-Comp.
This snapshot is from the Studio One 5.4 Plugin Manager, Statistics tab. I’ve no SD card reader or even a USB drive. 1 M2 hard drive and 2 x SSD drives with 32 gig ram and an I-9 processor and an 8 gig NVidea card. Once I remove the 6 WAVESVST DLL files into the Studio One Block list, everything is back to normal. No more freezing in the transport or delays. Waves support and I worked together for 90 minutes uninstalled and manually cleaned up Waves Central, reinstalled all plugins, loaded all of the MFC’s from 2005 forward in the Resources folder…and still at square 1.

PS the same holds true outside of Studio One v 5.4, this clearly shows a similar issue with Reaper as well when it loads the WAVES VST DLL’s.
There were multiple Terminate prompts for Waves
This doesn’t happen with any other VST 2 or 3 in my library.
Screenshot (122)

I am having the same problems with Waves plugins and multiple DAWs. I am not using an SD card. I have the latest version of Studio One and Reason and Pro Tools. FOr example RVERB took over 21 seconds to load. Waves please help us with this.

Hi - I posted this in another forum - this seems to work so far though ideally it’s not a complete solution:
11-28-21 An interim solution has been found with Waves loading slowly.
I spoke with Waves Support and we isolated the issue:
it was “The Waves Local Server”.
Here’s the solution: Close out of all applications using Waves (likely your DAW).
In Windows 10, open Task Manager. Under the Performance tab locate the Waves Server. Right Click and choose End Task
Next, on your C drive (or D if you installed Windows there), locate the folder
C:\ProgramData\Waves Audio\WavesLocalServer
Once you’re at this folder, delete the folder titled: WavesLocalServer.Bundle.
Now re-open your DAW and it should be quite fast (mine went from 30 second load time to under 3 seconds) as well as any plugin by Waves - all instantaneous.
If you need to purchase other plugins via Waves Central, go ahead and do so and activate and install, then simply repeat the process above until they (Waves) develop a solution.


PS I would open a case with Waves Support.

1 Like

Thats a good tip that tends to help with some issues that are related to upgraded plugins trying to read older data. Additionally, a cache delete & rebuild is sometimes handy in the case of AudioUnit issues.

I’m so happy to read, those other user have the same problem. I have some calls with waves but no solution. The tip with the Local Server is good, but no solution for the future.

After delete the Waves server and restart my PC, i have the same problem. The plugins from waves load for so much time. Some times it will be good and sometimes it load and load and load.
I work with Sequoia 15 and Cubase 11 - the same problem.

Is the problem only in windows or also mac?

To be honest, these are the guys that would be better to talk to.

Let us know what the solution is.

(post deleted by author)

There is no solution. I had 2 hours a support via TeamViewer. And the solution is: I have create a new user in windows with admin rights.

Actually, that’s often only necessarily just to reinstall stuff and get it working. In theory you can then delate that account and keep “administering” things from your regular account… In theory.

Wow! I can’t believe I found this solution! I run Win 10 64 bit, Studio One Pro 5.5, AMD FX 8 core, 32 GB RAM, all drives SSD’s.

About two weeks ago and all of the sudden, my Waves plugins started loading very, very slow, after having worked fine previously. The “R” plugins started freezing up my computer. I haven’t had a computer freeze on me in years! Studio One scanned the Waveshell files for almost 25 minutes one night. I called Waves support (which I don’t like as much as the plugins) and they were of zero help. I granted access to my computer which I never do, to try and get this thing figured out but the plugins loaded just as slow after some tweaking and the tech tried blaming EZDrummer because it froze…first and only time! I recently started removing Waves plugins from my songs in PSO 5 because they were no longer dependable.

Anyway, long story too long…I stumbled across your solution and it has made my Waves plugins load like they used to do…like all my plugins do, very quickly! Thanx for the post!

It’s too bad Waves couldn’t have supplied me with that info!

1 Like

Thanks for this note. There were a few Tips in this thread. Which is the one that worked for you ?

I wish to add one more TIP: after many weeks, I have also found MAPPING a Network Drive that is NOT in USE but still Mapped, will cause Waves to load very slowly and in my case crash Studio One (freeze) as well. No one had the answer, including Support or the Development Team in Tel Aviv. Oddly, it’s the only plugin / VST out of every one I own that causes this issue and that includes: Arturia, East West, KV, and many others.
I have several Mapped Network drives off this Desktop. Some are powered Off and Powered On only when needed. This is to save on wear and tear, infrequent use etc. This may occur if you have a Tablet or Laptop that is connected to your LAN and you go off Site, same scenario could occur.
Unfortunately Waves tries to access those disconnected Mapped Network drives which drags their plugins to a crawl when loading and may also crash your DAW. I discovered this by creating a second Windows account on this Desktop with No Mapped Drives. Studio One and Waves plugins (all) loaded fast and they worked fast. This led me to dig further, compare both accounts and figure out is this a Permissions issue or some other issue. Sure enough, after I Disconnected my Mapped Network Drives on the 1 User account, the issue was resolved and has been working fine since.


I did leave that part out, didn’t I. It was deleting the WavesLocalServer.bundle from the Program Data folder that got my Waves plugins running properly again. Waves is the only plugin that I have problems with. I own 38 Waves plugins and over 400 plugins total, most of which I no longer use.

Thanks, I am going to second this comment, this was the solution for me! I use my laptop at work on occasionally, so I have a mapped drive. If that drive is mapped and disconnected, Waves hangs when I load it up. As soon as I “disconnect” the drive, everything works perfectly.

1 Like

This should be at the top! Had the same issue and this solution works with Mac OS and Protools. HD\Library\ApplicationSupport\Waves\WavesLocalServer Delete Folder.


Man thank you so much for this!!!

1 Like