Re-Installed , Repaired but some VST3 are not showing

I was just cleaning my plugin directories, had to clean all my Waves plugins from my Catalina OSX macMini. (Its hard having just 256GB of hard disk space.)
I had to re-install the ones that I use so I downloaded the offline installers.
I have lots that are still v10, just 2 v11, some that are v12 and v13 and some more v14.
Install didnt go well and Reaper would fail to load them or taking too long to load.
I "Repair"ed then from Waves Central and they seem to be ok now BUT i noticed that some of them appear only as VST2 and not VST3, for instance the CLA signature series.
They worked before this with the same OS on this computer. Now I only see the VST2 version of them.
The thing is I only use VST3 for the most part so recalling my projects is not possible at this moment.

In not ready to WUP them up to v14 yet.
What can I do right now to fix this?

PS: Dont know if there are other posts with the same problem. If there are, then I apoligize. Please be kind enough to post link of similar threads.


Hi @alx396,

V9 and V10 will not work on OS 10.15 only V11 and up will work properly and were qualified and tested to run on OS Catalina.

That being said if you still encounter issues running also other Waves versions, please Contact Technical Support directly for quick assistance.

Thank you. Fortunately I got it to work. Not sure if this is a hack or if its an unortodox method.

I uninstalled everything and started installing again starting from v14 then all my v13 , moving to v12 then v11 and finally v10.
I had System Preferences >>> Security & Privacy open and at some point towards the end I had to Cancel whatever notification was showing and then giving permission from Security settings . This happened a few times then i chose OPEN on the final notification and giving permission again i think (i dont remember the order 100%) and it went through and everything worked. I can see the VST2 and VST3 plugins in Reaper and they all work.

I understand that v10 do not support OS 10.15 and Im looking forward to WUP up the ones that i will keep on using.

1 Like