Plugins V11 don't install on PC

I try to install the V11 plugins on my computer by waves central, it looks like normal but the plugins don’t appear in Waves folder and then they don´t appear on DAW.

Does anyone know what can be happening?

Hi, welcome to the forum!

Welcome to the Forum!

Find the correct article to help find plugins in your specific DAW here:

If you still can’t find them, please reach out to our tech support, they will get you up and running :slight_smile:


I already did that. Actually the problem is with the installation. I install by Waves central but the plugins don’t appear in waves folder. So they are not being installed.


Same problem here.
The plugins are activated but doesn’t install and nothing happens even the software saying that plugin was succefully installed.
The “activated” column is checked but in the “installed” column nothing change.

I really need a help


Hey @dicaetano,

Please call or write Tech Support and they will assist you in the quickest way possible.


1 Like

I am trying to solve this for 20 days and the Tech support just tell me to uninstall and reinstall and waves files and programs. But it didn’t solve

Please call Tech Support and ask for them to call you back to avoid phone costs, or reply to the email sent to you with your phone number and a good time (during Support opening hours) to reach you.


I have the same exactly problem! Just bought 2 plugins yesterday, It says installation completed successfully but it doesn’t install anything.

I’m facing the exactly same issue… Please, if you guys find a way to solve this, let us know!

1 Like

Found a solution!

After receiving a generic and very basic message from the support:

" To check if the plugins are installed, please go to C:\Program Files (x86)\Waves\Plug-Ins v11 and check if you can see .bundle files for the plugins you’ve installed."

I tried everything, installing previous versions, downloading offline installers, running installers as administrator, searching every file from waves and doing a complete clean deleting all of them and erasing Windows registries…nothing worked!

What resolved the issue was restarting the PC in Windows Safe Mode with network access, and from there installing the plugins via Waves Central. I hope it helps!


Amazing, Matheus… This solved the problem to me too…
However is not viable to change windows mode every time I want to install or delete a waves plugin. I’m talking with support to try to solve that, if they help me I’ll back to tell you.

Thank you


Emphasizing that there is an issue installing with Waves Central on Windows 7 currently.
Until this is solved you can email or call support +1 865 909 9200 ext 1.

The same problem on Windows 7. I wrote to the support service, but no one answers me. I will no longer buy Wawes products and will not advise others. Your company just fell in my eyes.

Wave’s V11 plugins are not supported in Windows 7, as mentioned here in the thread, but most of them can be installed in the previous version of the software (V10), which is supported with Win 7 64 bit.
If you have contacted the Tech Support during the weekend via the email, I’m sure you will be answered really soon.

In addition, quoting @OdelWaves last reply here:

Emphasizing that there is an issue installing with Waves Central on Windows 7 currently.
Until this is solved you can email or call support +1 865 909 9200 ext 1.

I know it. But I can’t roll back to version 10 using the Waves Central. And also in my account it is known that the products I bought are version 11. And I need 10. By the way, I wrote to the support team, but no one answers me.

Hi @zakup74 ,

For your reference, here is how you roll back your plugins to V10 (Using Central V11).
Or, how you simply Installing V10 plugins (Using Central V10).

In any case, as you still need to solve the Central issue, if you have reached Waves Tech Support via email and you still didn’t get a response. First, please make sure it is not in the spam-box.
If not, please resend the mail or call:
+1 865 909 9200 ext 1.

but are you installed with internet? in cabe alright???

Those reoccuring problems are just unacceptable!
After almost 30 years of DAW use and building severals DAWs by myself, I know more than enough to get things working. ALL plugins work, Native Instruments, Soundtoys, UAD, Arturia, Plugin Alliance, Fabfilter…only WAVES cause problems over and over again.
After going through all the troubleshooting provided by Waves with no success, I´m left with “contact tech support” - but I don´t want to call someone or establish a teamviewer session. I never had to do such things in the past with ANY software problem. I was able to solve those with some support by email and basic computer knowledge.
I´m afraid I have to say goodbye to Waves, when minor changes to my system, updates or the moon cycle can possibly mess with this ridicoulous copy protection scheme.

For what it´s worth, my problem for quite some time now: everything is installed correctly, but when selecting a Waves plugin in Cubase, it simply does not show up, and even crashes Wavelab.

To be honest every developer and every plugin ends up with issues at some stage, I’ve been digital doing this for around 15-20 ears and thats been pretty much my observation. Granted Wave plugins can be a bit more problematic than some, often its user error behind it.

Problems I’ve seen alot is…

  • Upgrading their plugins the latest “version” without upgrading the license
  • Trying to mix new plugins with old ones, such as V9, that aren’t compatible
  • Installing the plugins without installing there licenses
  • Moving the plugins from their default install location
  • Not running the correct version that is compatible with the DAW or OS

Not that I am suggesting this is your problem, just they are common user errors that I have encountered. Some of these things can cause problems plugins by other developers too. No developer can make something 100% “idiot-proof”, for want of a better expression.

Then there are other things like old cache or corrupted preferences that can throw a system out of whack. No one is at fault there, that is just the nature of digital technology. Machines have parts that can breakdown, analogue systems constantly need recalibrating and pert servicing, and digital technology slowly incurs transistor errors.

Those are easily fixed, though, by either reinstalling a plugin or deleting preferences and cache so the system can rebuild it error free.

1 Like

Hi @r_u_sirius and welcome to Waves Forum. :slight_smile:

I understand that issues as such may be frustrating sometimes.
The issue you are describing can be caused by a variety of reasons.
I can only say that Wave’s technical support department is full of professionals (who also happen to be very nice people as well), who will be more than happy to assist you and get you up and running. So don’t hesitate contacting them.

In the meanwhile, did you already try going through the troubleshooting steps found in this article?