WAVES.COM SPECIALS SUPPORT

Grand Rhapsody fx section not working

Hello,
I bought the Grand Rhapsody piano a while back and upon testing it everything seemed to work. I haven’t really used it since and yesterday upon opening it again I notice the whole right part of the control panel (comp, eq and reverb) do not work at all! Tweaking the knobs has no effect on the sound as well as switching the reverb on and off.

Another thing I noticed is that the samples themselves seem odd, the lower part of the piano give rather dry sounding notes while in the upper part the notes seem drowned in (natural?) reverb. Seems odd this would have been recorded like that so I figured it could have to do with the sample library somewhat being broken.

I went on to repair all plugin through Waves central, cleared the cache, and also tried to delete the libraries and reinstall them, to no avail.

I use Studio One 4 Professional. I also tested on FL Studio 12 as well as the standalone version to make sure it wasn’t a DAW issue. Same result.

I am out of my update plan and I hope this is not because of that! I’ve contacted Waves nonetheless.

Anyone experiencing the same issue?

Hi @tomatoKetchup,
please reach out to our support team, they will troubleshoot and ssit better then doing this publicly in the forum.

Thanks

Copyright © 2019 Waves Audio Ltd. All rights reserved. Contact Us | Terms & Conditions | Privacy Policy