Cosmos: How long should an initial scan take?

Installed it yesterday. M1 macBook Pro running Monterey (12.5) with quite a lot of external storage.

It says it’s ‘connecting to sample storage’ and may take… and I quote ‘a few seconds’.

Left it just under an hour last night. No progress so gave up and tried again this morning.

Restarted, No improvement. Reinstalled and tried again. We’re now deep into the second hour of ‘a few seconds’.

I can believe it if the first launch takes a while, and it’s just that the onscreen message is badly worded, but does anyone have any info on how long this thing actually takes?

Five hours now and no improvement. What do you think? Restart and try again? Or stick it out and see what happens?

Oh, PS. Just tried this. No dice.

  1. Quit COSMOS (also from the upper system toolbar icon: MicrosoftTeams-image (5))
  2. Go to Applications > Utilities and launch Activity Monitor.
  3. Locate the process named WavesPluginServer and end it.
  4. In Finder, click on the Go menu, hold [Alt/Option] and click on Library .
  5. Go to Application Support > Waves Audio > Waves Plugin Server .
  6. Delete the file named cosmos.sqlite.
  7. Launch COSMOS and rescan your sample folders.
  • Please make sure to scan the root directory of your samples and not any of its subfolders.

Ah! does this help?

Left it running overnight and got this error: A JavaScript error occurred in the main process

Uncaught Exception:

Error: Tray is destroyed

at NativeTheme. (/Applications/Waves/COSMOS/COSMOS.app/Contents/Resources/app.asar/main.bundle.js:1:61530)

at NativeTheme.emit (events.js:315:20)