WAVES.COM SPECIALS SUPPORT

Waves and Studio One 4.5.3

The Release Notes for PreSonus Studio One 4.5.3, just out, states the following:

“MacOS Mojave (10.14) and Catalina (10.15) users, please make sure that the plug-ins you’re using match Apple’s compatibility requirements before updating to Studio One 4.5.3. Incorrectly signed plug-ins will either be blacklisted by Studio One, or rejected by the operating system with this release.”

I am running macOS 10.14.6 Mojave, and I own Waves Diamond 10.0.1. Does anyone here know if I have anything worry about if I update to Studio One 4.5.3? Can you tell me if I’ll run into new blacklisting issues?

Hi,

Waves v10 plug-ins are properly ‘signed’ for OSX 10.14, so you can update to Studio One 4.5.3
All should work %100

Thank you very much. After receiving confirmations elsewhere, I did upgrade to Studio One 4.5.3, and experienced absolutely no problems with the Waves v10 plugins.

Copyright © 2019 Waves Audio Ltd. All rights reserved. Contact Us | Terms & Conditions | Privacy Policy