StudioRack doesn't show in Logic pr x

Though I have the new M1, i’m running Logic thru rosetta and it got rid of all the plugin issues I was having seeing as though waves doesn’t support M1 yet. However, StudioRack is in the Plugin Manager, the “use” buttons are rescanned and clicked. Yet its not there when I go to audio FX to use it.

StudioRack V11 is NOT compatible with Big Sur yet. My bad. Only V12 is so be waiting for an update.

StudioRack doesn’t appear to be compatible with anything these days. It used to work in Logic Pro 10.4.8 on High Sierra until Waves updated it’s graphics requirements.

It’s a shame as it worked perfectly beforehand. Having a Waves hiatus at the moment well for at least 6months unfortunately.

Hi All

@Sirrichardkingmusic welcome to the Waves forum :slight_smile:

Note that StudioRack is Officially Supported with Big Sur 11.0.1 using Intel processors only.

We are qualifying our products to support Apple M1 (ARM-based) processors, however, I don’t have an ETA at the moment.

@rodney_ferguson, if your computer used to work fine with StudioRack V11 prior to the ‘Metal’ requirements, please refer to this link and follow the steps to rollback StudioRack V11 to the previous V11 version and see if the issue is solved.

Hi Omry,

Thank you for the link to the offline installer for non-metal applications. I have managed to restore a working version of StudioRack for my system.



Hi @rodney_ferguson and @Sirrichardkingmusic.

Please note that we are officially supporting M1 with SoundGrid from today.

For more information, please refer to the Apple M1 Support for Waves Plugins page.

In order to set up SoundGrid on M1 system, please refer to the How to set up SoundGrid Apps and Driver on M1 Macs page.

Have a good day :slight_smile: