Apple M1 Waves Abbey Road Plugins Not Showing Up In Logic

Having a strange issue…

I have done multiple uninstalls and reinstalls via Waves Manager, full restarts, and still I only see two plugins in Logic in my Waves folder when inserting a plugin on a track: The free CLA echo-reverb and the Kings Microphone lol. I have used the full Abbey Road collection on my 2013 MBP 15" Retina, no issues. Easy install and authorizing process.

Is this purely an M1 issue? (Logic is in Rosetta translation, as I’ve learned that this is the way to run unsupported plugins)

In Logic in the Plug-In Manager I can see every plugin, all are authorized, but when I try to insert a plugin on a track… it’s just those two?


Hi @aidanknight

PLease follow the steps here to verify installation and licenses rescan in Logic if needed:

1 Like

Did that. Still only showing the 2 plugins.

@aidanknight, Then please reach out to tech support - they will help sort this out.

The Waves plugins aren’t “officially supported” by the M1 system yet. I was having similar issues.

1 Like

Here is a v12 plugin fix that worked for me.

go to rescan and MANUALLY scan 1 by 1 the plug that don’t work.

My sound other v12 plugs besides waves didn’t work either.

scan 1 at a time and they WILL WORK !!!

I have the same Problem. Have a new M1 and started Logic via Rosetta. I rescanned all plugins manually one by one but when I open a project with wave tunes files logic says that my system doesn’t support waves tune. that’s really frustrating. can anybody help?

The Waves Plugin shows fully verified in Plug in Manager but logic still says that waves tune plugin isn’t supported by my system. :frowning:

1 Like

HI Yishai,
I’m running Logic Pro X on an M1 in Rosetta. My waves plugs are installed correctly, validated / authorised and check marked in plugin manager. I am only able to select CLA epic and Mix hub from drop downs in the channel strips. Have run revalidation and restarts many times. Lost for next step?

Hi @michaelormond,

Unfortunately Apple M1 (ARM-based) processors are not yet supported with Waves V12.
This is stated here in our system requirements:

We are working to qualify and update our software to work there, but this may take some time and I do not have an ETA.
In the meantime, I cannot offer any troubleshooting steps or help resolve this.
Do you still own a previous Mac with Intel processor where the plugins run properly?

Yeah thanks Yishai. I do but it’s not up to the job anymore. I’m migrating everything from there now to see if I have better luck. I appreciate your reply. I’m aware of the situation regarding M1 processors and Waves v12. Not being supported as yet and know you’re under the pump. I’m just looking for a workaround using Rosetta.

Thanks again.

Is there perhaps some kind of “wrapper” you can load them in instead. Like StudioRack for example or the Blue Cat plugin chaining thing??

Just something to consider giving a try or asking others if they’ve had experience with it working.

Heya Simon. I worked out that I needed to migrate logic and waves plugs from the intel machine to the M1, then open logic in Rosetta and validate the plugs to the M1. All present and accounted for and running very well. That will hold me over nicely until I can go native when waves is rockin the M1.

Thank you for your help


1 Like

Hi Michael, could you explain what you mean by “migrating logic and waves plugins?” I’m in the same boat, switched from an intel machine to an M1, all plugins seem to work perfectly fine expect for Abbey Road plugins.

Hi Levi,
I just cloned my intel mac using migration assistant on my M1. That completely solved the problem……i had created the problem by installing logic on my M1 before I did this. The reason my waves stuff wasn’t working was because essentially they weren’t really there. Once my intel Catalina mac was cloned across everything was there and working. Does that make sense? I have only one Abby road plug. The J37 tape machine. It is working fine on the M1 in Logic 10.6.1 operating on Big Sur in Rosetta.


Hi Ernie, how are you manually rescanning 1 by 1? I’ve done the full rescan by clearing the cache & forcing a full reset, Logic is successfully validating all my Waves plugins but during scanning reports 11 that won’t work and these don’t show in the plugin selector for the channel strip. I’m running Logic in Rosetta and can see some of the plugins but none of the CLA suite for example

I’ll try to remember that tip if anyone else asks!! Good one, man!!

I am also facing this issue :anguished:

Exactly the waves plugins are not officially supported.