WavesLocalServer...what is it and why doesn't it quit when I quit my DAW?

Hello,

Upgraded to Waves v12 today, and immediately noticed more resources being used than v11 on my Mac. Went to Activity Monitor and see “waveslocalserver” as one of the top three Memory hogs, and it’s still running despite the fact that I’d quit Pro Tools over an hour ago.

What is this, why doesn’t it quit when I quit Pro Tools, and how can I make it do so without constantly having to visit the Activity Monitor?

I registered to complain about the same thing on Windows. Quitting the DAW still leaves this running.

I find if you rename the executable so it never runs, the new preset browser doesnt appear in the “load” menu. I’m not sure what else is affected though.

I actually saw your complaint on the Cakewalk forums when I Googled “waveslocalserver v12”. Looks like you and I got Windows and Mac covered, respectively. :wink:

I’m really just annoyed that it continues to eat up RAM after I quit Pro Tools, and I have to manually quit the process. I hope enough people complain and something gets done about it.

This is what my Activity Monitor looks like after I quit Pro Tools.

Screen Shot 2020-10-21 at 12.02.23 PM

Hi @robbadobba,

WavesLocalServer is a background process that is used to facilitate cross plugin communications, preset scanning, advanced plugin features and licensing abilities.
This service does not collect or transmit any personal user information or usage data.
The reason this service stays open in the background is to optimize loading and scanning times. We are working to minimize the resources it requires.
There is no problem if the service is terminated, but it will be relaunched by the plugin once it is needed.

Thanks

Please give us an option to have the process stopped when the DAW is closed.

1 Like

Hey @funk,

I have passed this request on to our Dev team.
Appreciated!

1 Like

Thank you @YishaiWaves :slight_smile:

Seconded. There are no good reasons for this not to quit when the DAW does, and free up the RAM.

2 Likes

Created a forum account just for that, this is annoying and I can’t even understand how the Waves team through it would be a good idea to have a .exe eating memory while doing NOTHING when your DAW is not even running anymore. Also people hate when some ghosty stuff are running in the background, I mean, not trying to sound rude but come on, this is some low level stuff. Just kill the task when we closed our Daw or something.

I saw that deleting the exe (or even the whole folder WavesLocalServer ) will fully get ride of it, but like funk said, it will also remove the new preset loading menu (which is kind of useless anyway)

Still, I hope you’ll resove this issue ASAP.

I’ve had issues with this application. My mouse keeps jerking and hesitating. I went through all startup activities. When I suspend WavesLocalServer, my mouse will work again without any issues. I think there’s too much resource polling going on even when I’m not using my DAW which is preventing the mouse to work normally.

Now it’s April 2022 and this still is still running in the background permanently, even starting with windows startup. Why is that, Waves, didn’t you read the memo? People don’t like shady stuff running in the background all the time! Start it with the first plugin loaded, and shut it down with the last plugin unloaded.
And if your dev team tells you this is hard to do: no, it is not.

1 Like

hello i have same problem we want solution
waveswatchdog.exe
waveslocalserver.exe
( 20% RAM USAGE )
No recording no plugins i watch youtube only for now
why those always running in the background .?

Bump.

Glad Waves have admitted there’s no benefit to the company to leave it running in the background. Since that’s the case (and since not everyone has a dedicated mixing machine), I’d bet most folks can afford to wait an extra fraction of a second for any plugins to load/scan. (Or NOT load, since the service will start when ANY program does a VST scan, WHETHER OR NOT ANY WAVES PLUGINS ARE ACTIVELY BEING USED.) (Emphasis mine.)

Anyway, since it’s been two years since it was “passed to the dev team,” and it’s still not fixed, here’s a lame workaround.

  1. On Windows, open your Task Manager, click on the “Startup” tab, right-click on “WavesLocalServer”, and click “Disable.” That will stop it from running on boot. (Again, why isn’t it running on-demand?)
  2. When it inevitably starts running, but you’re not using it and want it stopped, you can kill it from Task Manager. If you want a slightly quicker way, copy the following (case-sensitive) line into Notepad…

taskkill /F /im WavesLocalServer.exe

…save it as a .bat file somewhere convenient (might have to make sure file extensions are visible), then double-tap that file whenever you want to kill it.

And I guess, on the Mac side, we’d just go into Activity Monitor and quit (or Force Quit) “WavesLocalServer” at will.

I just checked, and on my system, it’s currently using 41.6 MB of memory. There are about 30 other processes each using more than that.

At the end of the day, unless you have 8GB or less of RAM, does that even matter? That’s probably Waves’s thinking…

From what I’ve observed, it doesn’t kick in until we use something Waves related. Then it slowly scales depending on what and how much we’ve used. The plus side to this is performance enhancements… from what I’ve observed.

It seems really silly that they’d want to collect your data as you have already given them your data when you bought your plugins. The fact they haven’t sold any of that information negates any concerns for server data or whatever. Security and the privacy of your information is certainly no joke, and in all the years I’ve been using Waves I’ve never seen them treat it like one.