COSMOS unable to connect to database

I stared at this for an hour, then saw a comment on here to reboot, so I did, then stared at it for 1.5 hours. It’s just not connecting. It’s worked in the past but I haven’t used it in many months.


I’m on Windwos Pro 10 1909

Anyone have any ideas?

Hi Bud,

Sometimes restarting Windows and trying to relaunch Cosmos solve the above issue.

It is worth mentioning that in order to run Cosmos on a PC computer you must have a processor that includes AVX support. (this information normally shows on the processor’s product page).

You can also reach for support directly Contact Technical Support to verify if your processor type support AVX, or to further troubleshoot the issue if required.

I have restarted and relaunched several times and that hasn’t fixed it.
My processor supports AVX and AVX2: it’s a Ryzen 9 3950X


Actually, while typing this I decided to uninstall and reinstall once more, and for whatever reason that fixed it ( I did check once again to see if it would connect before uninstalling and it didn’t).

Thanks for the suggestions and info.