X-Noise plug-ins not working in Studio One 4

For some reason the X-Noise plug-ins (Mono/Stereo) are not working in Studio One 4. This has only happened within the last month. Currently, I’m trying to use X-Noise Mono, but it’s not loading. I have used X-Noise in the past quite often without a problem. It is currently listed on Inserts with red lettering indicating inactive. When I remove it from Inserts and then select it again to put it back, I get nothing. X-Noise doesn’t even attempt to load. I also tried to use X-Noise Stereo, to no avail. I’m using Windows 10 Pro with all latest updates. I bought these plug-ins as part of the Restoration bundle. I have tried everything I can think of that could be causing this problem, including:

  1. Reset blacklist;
  2. Go to Plug-In Manager and “Remove Plug-In Settings” and re-scan for plugins;
  3. Re-install Studio One;
  4. Upgrade Restoration bundle to Version 13;
  5. Re-install Restoration bundle;
  6. Make sure licenses are activated;
  7. Re-install Waves Central. I’m currently using Waves version 13.0.10;
  8. Look at Windows 10 virus protection to determine if the plug-ins or something related is being blocked. Found nothing.

Every time I start Studio One, I get the below Missing Devices error. At this point, I’m stumped.

SOLVED: Updating to Waves Central 3.0.12 has solved the issue of X-Noise plugins not working.

1 Like

That seems to be good news bro.

1 Like