WAVES.COM SPECIALS SUPPORT

My plugins are not compatible

it keeps saying that the plug ins arent working becuase they are uncompatible but i dont know what that means

Hi Chris,

It’s always best to contact Tech Support directly with this inquiry…
In general, I can suggest providing this type of information in order for our Forum members to be able to assist here:

  1. Can you type in the exact error message that you are getting on-screen?
  2. Which application provides you with this error message?
  3. Which Operating System version are you using, and which DAW/Music Application will you be using these plug-ins with?

Have a quick look at these links and see if your Waves plugin version is compatible with your OS and DAW.

https://www.waves.com/support/tech-specs/system-requirements
https://www.waves.com/support/tech-specs/supported-hosts

It may be that you need to update your plugins which can be done via Waves Central. Be aware though, that if you feel you need to do a bug reinstall or spend quite a bit of money on WUP, make sure you talk to a Tech first. It may be that type of thing could be avoided.

Copyright © 2019 Waves Audio Ltd. All rights reserved. Contact Us | Terms & Conditions | Privacy Policy