WAVES.COM SPECIALS SUPPORT

Many IR360 B-Format impulse responses have severe processing flaws

Long post, but please bear with me.

Initially, I had noticed many of the stereo to B-Format IR’s included in IR360, did not behave in the way you would expect. Primarily, when you panned left, the reverb would of course audibly pan left, but when you panned right, it would often stay panned left. Additionally, when panning right, the reverb would lose almost all of it’s direct signal, so it sounded much more distant. I noticed this was a trend in a large portion of the presets, and it is not a matter that can be explained away because these are real acoustic spaces. The true stereo IR’s of the same space, same source, same microphone location sound exactly as you’d expect when centered or panning. It’s only the stereo B-Format files that have this issue. Further still, it’s not a routing issue or anything DAW related, as the internal meters within IR360 confirm it.

So I started looking into this deeper. The stereo B-Format IR’s are 6 channels, the first 3 (W, X and Y in ambisonic terms) dedicated to the left input, and the second 3 dedicated to the right. When I started opening some of these files in a wav editor, I discovered that in all of the affected IR’s, the 4th and 6th channels direct signal was simply incorrect, smeary, and low. It’s obvious enough that I can just look at one of the files and know it will be a problem without hearing it. I then setup my own signal chain in a different convolver, outputting to an ambisonic decoder plugin, and was able to confirm doubly that it’s an issue with the IR’s themselves, and not the IR360 plugin.

My best guess, is that some part of the initial editing process went wrong. And there are several things that could have gone wrong, converting A format to B format, processing two 4 channel IR’s into a single 6 channel IR etc.

So I would really appreciate a response from WAVES on this issue. The B-Format IR’s are one of the most unique and valuable parts of it’s library, even for stereo work. I think it’s a serious issue, and I would hope WAVES still has access to the source files to be able to fix it.

Thanks

Hi @motsm and welcome to our forum!

We are looking in to your inquiry, but so far have not been able to reproduce the behavior you are describing. I have a couple questions:

  1. What version of Waves IR360 are you using? V11? V10? You can click the little “W” icon on the top left corner of the plugin to find out

  2. What Operating System are you running? Let’s make sure it’s compatible with the version of Waves you are using… Note that Logic 10.5 is not yet supported by Waves due to routing issues, could this be the issue?

  3. What DAW and version are you running on? Let’s make sure it is one that is supported with the version of Waves you are using…

  4. Does this happen with a particular IR or IR’s? (If so, which ?)

  5. Dios this happen with a particular IR360 sub-component? (If so, which ?)

Thanks

It only appears within particular presets, yes. The church IR’s seem to have more affected presets than other groups. But I haven’t gone through everything.

This is something I didn’t get into in my first post, as I was trying to keep it as simple as possible. But now that I have your attention, I’ll explain some of my findings, with accompanying screen grabs in Audacity. Hopefully this makes it clearer.

This is an image of the stereo B-format IR, of the Presidio Chapel. I have drawn a colored line after a few of the more substantial reflections in the IR. Remember, that channels 1, 2, and 3 represent B-format for the left source, and 4, 5, and 6, represent B-format for the right source. Now, notice that channels 4, and 6 align with each other, but not with any of the other channels within the IR.

In this second image, I have shifted channels 4 and 6 to a point in which all of the reflections roughly align as they should. But this obviously leaves an empty space, where all of the other channels contain the direct signal and initial early reflections. In channels 4 and 6 however, they are simply gone, completely cut off.

Continued in next post…

Finally, this is an image of the Disney Concert Hall, stereo B-format IR. Which is an IR that does NOT have this issue. It sounds exactly as it should, and that can easily be seen in the below image. Notice that each of the major reflections are represented in all 6 channels, and are aligned as you’d expect. Of course there are slight alignment differences between the first 3, and second 3 channels, as they represent left and right sources, as I explained earlier.

I understand it may be hard to simply take my word for this, since I’m just some nobody on your forum. But PLEASE give this the attention I think it deserves. I have checked and rechecked this from so many different angles, in an attempt to find how I might be wrong. But every single time, I’ve come to the same conclusion, the IR’s themselves are the issue. I could make examples of many different IR’s to back up my claim here, but it’s time consuming, so for now, I have left it at these included images.

Of course I’m leaving myself open to mistakes, it’s always possible, but I find it unlikely at this point.

I appreciate your time

I realize you may still want to recreate this issue audibly. So please set up the stereo B-format IR360 on a send, load the Presidio Chapel IR, and make sure to load the “pure convolution” preset. Now to make it very easy to hear, set the balance 100% front.

Personally, I found a dry drum loop exposes this issue the most, as the percussive strikes are affected quite heavily by the missing direct signal. Anyway, whatever your sound source, make sure it’s muted, so you can only hear the 100% wet reverb send. Now simply pan the source track, left, and then right. As you pan right, you should hear the reverb sound much more distant, and still remain mostly in the left channel.

Thanks for the detailed answer @motsm!

There is an issue with this however - you are using Audacity as you host application and presenting all your finding there.

Audacity is not an application supported or qualified to work with Waves plugins.
Here is a list of the DAWs we support: https://www.waves.com/support/tech-specs/supported-hosts

It makes sense now that the routing is off and may be due to this.
I am sorry, but could you possibly try to recreate this with a supported host such as Reaper, Cubase or Protools?

Thank you

I am not using Audacity as a host, perhaps I wasn’t clear enough with my explanation of the pictures.

I used Audacity to open the impulse response files themselves, the .wir IR’s, the actual RIFF data of the impulse responses, that is what you are seeing in the images. The images above are not processed through the IR360 plugin, or any other convolver, they are not ran through a host, so they are not affected by routing whatsoever. It is the raw, unconvolved, 6 channel, 32bit, 96khz IR data within the .wir files, normalized, but with no other processing.

So please re-read posts 3 and 4 as thoroughly as you can, while keeping what I just explained in mind.

Just as an FYI, I have recreated this issue within REAPER several times, and other DAW’s as well. So I encourage you to recreate the issue yourself, like I outlined in post 5.

Thank you

I see.

Before I move this back to our developers, please respond to the other questions I have asked earlier:

  1. What version of Waves IR360 are you using? V11? V10? You can click the little “W” icon on the top left corner of the plugin to find out

  2. What Operating System are you running?

  3. Does this happen with a particular IR360 sub-component? (If so, which ?) Which component are you using?

Currently I have V9.92 installed, but also tried V11. Both had the same issue.

I am on Windows 7.

By sub component, I think you mean which specific plugin? It’s the VST3 “IR360 sound field Stereo/5.0”

I was reluctant to answer that earlier, as it would be barking up the wrong tree to look into the plugin, DAW, or operating system. I just can’t stress enough, that the issue is within the audio files themselves.

For the dev’s that may read this post, I’ll summarize a bit. This only affects some stereo B-format IR’s, and from what I have seen, it’s always channels 4 and 6 (of the IR file itself, not the output of the plugin) that have problems in the affected IR’s. So as I outlined in posts 4 and 5, you can start with the Presidio Chapel stereo b-format IR, as a clear example of the issue that affects many other IR’s within the library.

Thank you

Hey @motsm,

Thanks for the additional info.
We are indeed identifying incorrect delay alignment in several IR’s and are investigating this issue.
I will get back to you here when I have more infor or an ETA for a fix.

Thank you very much for brining this to our attention. :star_struck:

Yishai

Great, I’m glad you were able to identify the issue on your end.

By the way, I have a somewhat related question, one that pertains to the IR360 library, and since the dev’s are digging into the library, I figured it might be a good time to ask it.

There are several presets that are documented as having impulse responses recorded with a Soundfield microphone, as you can read within the IRx Album PDF from waves. But unfortunately, with some of these spaces, the Soundfield IR is missing from the library. As an example, this is taken from the IRx Album PDF.

“Kirishima Capture Date: February 18, 2003
Location: Kirishima, Japan (Near the city of Kagoshima)
Source Type: Dodecahedron
Source Locations: Center, Left, Right
Mic Locations: 4 (see diagram - points 1,2,3,8)
Mic Setup: Neumann SKM-140 (ORTF setup), Soundfield ST-250, Neumann KU-100 head
Summary: IR Capture with Farina in Japan.”

Funnily enough, you can even see the Soundfield microphone in one of the WAVES photos of Karishima from the recording session. But the Soundfield impulse responses do not exist within the library. So it’s a bit disappointing not having these impulse responses, when they appear to be advertised as included.

I don’t mean to pile on with issues here, but thought it an appropriate opportunity to bring this up.

Thanks again for your support

Copyright © 2019 Waves Audio Ltd. All rights reserved. Contact Us | Terms & Conditions | Privacy Policy