WAVES.COM SPECIALS SUPPORT

Important Note about **macOS 10.15 Catalina**

Dear Waves users,

During October, Apple will release a new operating system, macOS 10.15 Catalina .
We are working closely with Apple to ensure that our software is compatible and that your Waves plugins and applications will work properly.
However, until we confirm full compatibility, we strongly recommend you remain on your current version of macOS.

In the meantime, please note:

  • Waves plugins v10 will open in macOS 10.15 Catalina but are not officially supported.
  • Waves’ eMotion LV1 mixer v10 will open in macOS 10.15 Catalina but is not officially supported.
  • Other Waves applications (MultiRack, StudioRack, SoundGrid Studio) are not supported and will not open in macOS 10.15 Catalina.
    We will update you very soon about macOS 10.15 Catalina compatibility developments.

Best regards,
The Waves Team

Hi there,

is there any progress with the macOS 10.15 Catalina?

When you say that plugins v10 and eMotion LV! mixer v10 are not officially supported, what do you mean with this?

Best regards
T.P.

Copyright © 2019 Waves Audio Ltd. All rights reserved. Contact Us | Terms & Conditions | Privacy Policy